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PowerPoint 2007 Cheat Sheet

Confused by the app's new look? We can help.

Preston Gralla

March 6, 2008 (Computerworld)

PowerPoint users, your world has changed. The newest version, PowerPoint 2007, features the
most thorough changes since the program's birth.

This is good news. PowerPoint's new look is more than just a pretty face -- it makes it far easier
to create powerful presentations. Including multimedia is now simpler than ever, for example,
and there are a host of other new tools as well. Get used to the new way of doing things, and
you'll save time, be more productive and create better presentations.

It may take some time to get used to PowerPoint 2007, though. That's where this article comes
in. We'll give you a guided tour of the new interface, show you what's new, and offer tips and
tricks for getting the most out of PowerPoint 2007.

Get the lay of the land

The PowerPoint 2007 interface represents the biggest change Microsoft Corp. has made to the

look and feel of the program and to how you get to its myriad features. No matter what you do --
from creating new presentations to editing styles, creating animations or even just using a menu
-- you'll find things have changed.

Here's a quick guided tour to the PowerPoint 2007 interface:

1. The Microsoft Office button. The big button on the upper left-hand corner of the (D
screen replaces the old File menu from previous versions of PowerPoint. You'll find ' _%‘/
familiar features for opening files, saving files, printing files and so on, but there's a lot

more here as well, as you'll discover later in this guide.

2. The Quick Access toolbar. To the right of the Office button is the Quick 5 - n
Access toolbar, with buttons for using PowerPoint's most common features,

including Save, Undo, Redo, Quick Print, Print Preview, showing a slide show from the beginning
and more. You can add and remove buttons for any functions you please. More on that later as
well.

3. The Ribbon. Love it or hate it, the Ribbon is the main way you'll work with PowerPoint.
Instead of old-style menus, in which the menus have submenus, and the submenus have sub-
submenus and so on, the Ribbon groups small icons for common tasks together in tabs on a big,
well, ribbon.

So, for example, when you click the Insert tab, the Ribbon appears with buttons for items that
you can insert into a presentation, such as a picture, clip art, a chart, movies or audio clips.

If you've spent years getting to know PowerPoint's old interface, you'll likely be frustrated at
having to learn a whole new interface. But even if you hate the Ribbon initially, it can be your
friend; check out the section "Learn to love the Ribbon" for details.




4. The View toolbar. There are no longer several set13 ofztoolbars at}he bottom of PowerPoint;
their functions have been replaced by
the Ribbon. The View toolbar, which
used to be at the bottom of the slide
sorter, has been moved to the bottom of
the screen. It lets you choose between
Normal, Slide Sorter and Slide Show
modes. There's also a slider that lets
you zoom in or out of your presentation
or individual slides.

No right-hand pane. In PowerPoint
2007, the right-hand pane from previous
versions has been banished; its
functions have been replaced by the The PowerPoint 2007 interface.
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But the truth is, once you learn to use it, you'll find that it's far easier to use than the old
PowerPoint interface. It does take some getting used to, though.
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The Ribbon, by default, is divided into seven tabs, with an optional eighth one (Developer) that
you can display by clicking the Office button and choosing PowerPoint Options > Popular > Show
Developer tab in the Ribbon.

Here's a rundown of the main tabs and what each one does:

Home: This contains commonly used PowerPoint features, such as creating new slides,
changing layouts, deleting slides, formatting text and paragraphs, inserting shapes, and creating
drawings.

Insert: As you might guess, this one handles anything you might want to insert into a
presentation, such as pictures, clip art, charts, tables, movies, audio clips, photo albums (a new
PowerPoint feature), headers and footers, text boxes, WordArt ... well, you get the idea.

Design: Here's where you'll apply different themes to your presentation; change colors, fonts
and effects; select background styles; change the slide orientation and page setup; and so on.

Animations: A more accurate name for this might be transitions, because it lets you control the



animations used as transitions between slides. Creating transitions is now exceptionally easy: All
you need to do is hover your mouse over an icon representation of a particular transition on this
tab, and you'll see a live preview of that transition.

You can also create custom animations, change transition sounds and speeds, and make other
changes to animations as well.

Slide Show: Here's where you'll accomplish whatever you need to do with your slide show -- set
it up, create a custom slide show, preview it from the beginning or current slide, rehearse your
narration and timings, change the resolution, and so on.

Review: Need to check spelling and grammar, look up a word in a thesaurus, mark up a
presentation with comments, or review other people's markups? This is the tab for you.

View: Here's where to go when you want to change the view in any way, including changing
presentation views -- such as slide master, handout master, notes master and slide sorter. You
can also show or hide a ruler and gridlines; zoom in and out; choose from color, gray scale, or
black and white; and display windows as either split or cascaded.

Developer: If you write or use macros, this is your tab. It also lets you insert controls such as
buttons and text boxes, if you have written code for them.

As you can see below, each of these tabs along the Ribbon is organized into a series of groups
that contain related commands for getting a specific task done -- in our example, handling fonts.
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Ribbon organization.

Inside each group is a set of what Microsoft calls command buttons, which carry out commands
and display menus. In the example, the featured command button changes the font size of the
presentation.

There's also a small diagonal arrow in the bottom-right corner of some groups that Microsoft
calls a dialog box launcher. Click it to display more options related to the group.

All that seems simple enough ... so it's time to throw a curve ball at you. The Ribbon is context-
sensitive; it changes according to what you're doing. Depending on the task you're engaged in, it
sometimes adds more tabs, subtabs and supertitles.

For example, when you highlight a picture, the Picture Tools supertitle appears. Click the Format
tab when Picture Tools appears, and several new groups appear, including Adjust, Picture
Styles, Arrange and Size, which let you edit and format the picture.



Other "now you see them, now you don't" supertitle
SmartArt Tools -- all of which appear in

response to various actions you take in
PowerPoint.
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There are two more new PowerPoint

tools that you'll want to get to know: the Office button and the Quick Access toolbar. Think of the
Office button as a greatly expanded File menu from the PowerPoint 2003 days -- the File menu
on steroids.

This is where to go for the various Open, Save, New, Print and related options and includes a list
of all your recently opened files. But there are two particularly noteworthy new features here as
well -- Prepare and Publish.

Publish does exactly what it says: It gives options for publishing a document. If your company
uses a document management server or SharePoint, you can publish it there. Another Publish
option lets you package a presentation by copying the presentation and links to a folder that you
can then burn to a CD. And yet another option lets you open the presentation in Word, where
you can create custom handout pages.

Use Prepare when you've finished your presentation and are ready to share it with others. There
are plenty of great options here, such as marking a document as final, encrypting the document,
inspecting it for hidden metadata and information you'd prefer remain private, and adding a
digital signature. Because PowerPoint 2007 isn't yet widely deployed, a particularly useful feature
here is running the Compatibility Checker, which will let you know whether your presentation
contains features not supported by earlier PowerPoint versions.

For those who like to fiddle with the
PowerPoint interface and how it works,

the PowerPoint Options button, located
at the bottom of the Office button's box,
lets you customize PowerPoint in many
ways, including determining your overall
color scheme and how the slide show
should work. It has many of the features
that you accessed via Tools > Options in
previous versions of PowerPoint, plus
more. It's far better organized and
easier to use than Tools > Options was.

Even those who can't stand the

The Office button menu.
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PowerPoint makeover and the Ribbon will find at least one thing to cheer about -- the Quick
Access toolbar. This nifty little tool seems innocuous enough, but spend some time with it, and

you'll be impressed.

The three buttons on the left -- Save, Undo and Redo -- are useful but not

particularly noteworthy. But you can add buttons to the Quick Access toolbar
so that just about any PowerPoint feature or option will be available on it. There are several ways

to do this.



To the right of the Redo button, the nearly invisible Down arrow is the key to the Quick Access
toolbar. Click it, and you'll be able to add and remove tool-bar buttons for a preset list of 10
commands. To add buttons for additional commands, select More Commands from this list. The
screen below appears. (You can also get to this screen by clicking the Office button and
choosing PowerPoint Options > Customize.)
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Adding buttons to the Quick Access toolbar.
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There are plenty of others you can add.

Click the drop-down menu under "Choose commands from" at the top of the screen, and you'll
see other lists of commands -- All Commands, Home Tab and so on. Select any option, and
you'll see plenty more commands you can add.

Finally, there's an even easier way to add a command. Right-click any object on the Ribbon and
choose "Add to Quick Access toolbar." You can add not only individual commands in this way,
but also entire groups -- for example, the Cell Styles group.

Once you've got the Quick Access toolbar customized to your liking, you will hardly ever have to
use the Ribbon.

Five tips for working with PowerPoint 2007

If you're a longtime PowerPoint user, you no doubt have accumulated a set of shortcuts and
customizations. Many of those have gone away under PowerPoint 2007. But fear not, because
there are plenty of ways for you to bend PowerPoint 2007 to your will. Here are some tips to get
you started.

1. Turn off the Ribbon.

Here's what may be the best tip you'll ever come across for PowerPoint 2007 -- how to turn off
the Ribbon. Doing this will get you back plenty of screen real estate.

The Ribbon will still be available when you want it -- all you need to do is click on the appropriate
menu (Home, Insert, Page Layout and so on), and it appears. It then discreetly goes away when
you are no longer using it, as you can see in the screen shot below.

There are several ways to turn off the
Ribbon:

e Click the Down arrow to the right of the
Quick Access toolbar button and select
Minimize the Ribbon.

e Press Ctrl-F1. (Press Ctrl-F1 to make it
appear again.) l . A New Tomorrows

e Double-click the current tab above the The incredible disappearing Ribbon.




Ribbon. Click to view larger image.

2. Get your PowerPoint 2003 toolbars back.

Say you've given the Ribbon a fair shake and you just can't stand it. Although Microsoft doesn't
provide a way to get the old PowerPoint 2003 interface back, a couple of third-party tools, Classic
Menu and ToolbarToggle, do. See our story "Hands on: Show Office 2007 who's the boss" for
details.

3. Customize the Ribbon.

Maybe you mostly like the Ribbon, but some of the commands aren't located where you'd like
them to be. Another third-party program called RibbonCustomizer Pro lets you create new
Ribbon tabs or customize existing ones the way you like them.

It's a powerful way to take advantage of the Ribbon's interface while asserting control over which
commands appear where. Again, see "Hands on: Show Office 2007 who's the boss" for more
information.

4. Use keyboard shortcuts.

If you're a fan of PowerPoint 2003's keyboard shortcuts, take heart -- most of them still work in
2007. So keep using them.

You can also use a clever set of keyboard shortcuts for working with the Ribbon. Press the Alt
key, and a tiny letter or number icon appears on the menu for each tab -- for example, the letter
"H" for the Home tab. (See the image below.)
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Using the Alt key helps you master the Ribbon.

Now press that letter on your keyboard, and you'll display that tab or menu item. When the tab
appears, there will be letters and numbers for most options on the tab as well.

Once you've started to learn these shortcuts,

you'll naturally begin using key combinations. . . .
So instead of pressing Alt, then H to display the ~ PowerPoint 2007 Alt key combinations

home tab, you can press Alt-H together.

Key combination Function
The table to the rlght shows.the most AlLF Office button
useful Alt key combinations in
PowerPoint 2007. AltH Home tab
) . Alt-N Insert tab
5. Find your old friends.
Alt-G Design tab
In PowerPoint 2007, no features or
Alt-A Animations tab

functions are where they used to be. But
it's easy to find them. Use our Alt-S Slide Show tab
PowerPoint 2007 quick reference charts

. . , Alt-R Review tab
for an extensive list of where to find your
favorite commands. Alt-W View tab
Alt-L Developer tab

New features in PowerPoint 2007



Changes are more than skin-deep in
PowerPoint 2007; there are plenty of new features as well.

New file format

Under the hood, one the biggest changes to PowerPoint is the new Office XML format -- all
Microsoft Office applications now use it. By default, PowerPoint saves in this new format, which
has the .pptx extension, or the .pptm extension if the document contains macros.

For businesses, this can be a big plus, because it allows for easier integration with enterprise-
level applications and for exchanging data. In some instances, it also creates files of a smaller
size, because files are automatically compressed when they're saved to disk and then
automatically uncompressed when you open them.

In addition, the new format makes it easier to recover damaged files because it saves different
data components -- such as tables and charts -- separately from one another. This means files
can be opened even if an individual component, such as a chart, is damaged.

That's the good news. Here's the bad news: Most of the world doesn't use the new format and
won't for some time. If you create a presentation and save it in the PowerPoint 2007 format, no
one with a previous version of PowerPoint will be able to view it.

To save your presentations for these users, click the Office button and choose Save As >
PowerPoint 97-2003 Presentation.

To save all your presentations in that format by default, click the Office button, select PowerPoint
Options > Save, and from the drop-down list at the top of the page, choose PowerPoint
Presentation 97-2003, and click OK. From now on, any presentation you create will be saved in
the older format.

Themes

One of the most welcome new features is Themes, which allows you to quickly apply common
colors, backgrounds and fonts to all elements of a presentation for a unified look. In previous
PowerPoint versions, you had to make those changes separately for charts, tables and slides,
which was time-consuming and difficult and could lead to errors.

To apply a theme to a presentation,
click the Design tab and roll your mouse

over each theme in the Ribbon to see — B
how each will look. Each theme will be e
applied to the main document itself as
you roll your mouse over it. When you
find a theme you like, click it to keep it.
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Be aware that Themes only work if
you're using PowerPoint's new Office
XML format; they won't work on old-
style .ppt files.

Previewing a theme.
Click to view larger image.

Custom slide layouts

You can now create and save customized layouts for your presentations, including charts,
movies, tables, pictures, SmartArt, clip art and other elements. You can also create and save



multiple slide master sets that contain different customized layouts for different topics. You get to
it from the View tab by clicking on Slide Master. From there, you can create and save new
custom layouts.

SmartArt

In PowerPoint 2007, you get far better prebuilt diagrams and charts via SmartArt. From the Insert
tab, click SmartArt, and you'll be able to insert a wide variety of diagrams and charts, as you can
see in the figure below. Click any of the available diagrams or charts, and you'll get a description
of what it's best used for and how to use it.

In addition, you can add a variety of
effects, such as gradients and 3-D :
effects, to SmartArt and other ’=
PowerPoint graphics. You can also -
convert existing content to SmartArt, for
example, by right-clicking a bulleted list
and selecting "Convert to SmartArt."

You'll then be able to port the list into a : _
. SmartArt offers many new types of diagrams and charts. Click to
prebuilt SmartArt template. view larger image.

Better multimedia integration

It's now easier to incorporate multimedia into your presentations. Go to the Insert tab, choose
either Movie or Sound from the Media Clips group, and insert your multimedia object.

From here, you can also play a CD audio track during the presentation. And you can even record
audio directly from within PowerPoint and embed it in your presentation.

New effects

There are a slew of new and better effects in PowerPoint 2007, including warp, bevel, shadow,
reflection, soft edges and rotating 3-D shapes. You can get to these effects in a variety of ways,
depending upon where you're using the effect.

For example, if you're using an effect on
a picture, put your cursor on the picture,
select the Format tab under Picture
Tools (this appears only when you've
selected a picture). From the Picture
Effects drop-down list, select the effect
you want to use.

Discontinuous text selection

OK, this one isn't earth-shaking, but it's

an example of a very small change that

can save lots of time. You can now Adding new effects to pictures.
. . . . Click to view larger image.

select multiple pieces of discontinuous

text and then make changes to them en

masse, such as applying a font or size change.

Do it the same way you do it with Word -- hold down the Ctrl key as you select text. Then apply



changes to all the text simultaneously.
Get going

As you can see, PowerPoint is full of

new features, even if you may have a In this series

hard time finding your way to them. But + Word 2007 Cheat Sheet
armed with our cheat sheet and a little o Excel 2007 Cheat Sheet
elbow grease, you can get to the good e PowerPoint 2007 Cheat Sheet
stuff in no time.

For more tips and help on PowerPoint 2007, head to Microsoft's PowerPoint 2007 site.




